MP4を「全シーンを出力」すると一部シーンの音が出力されない

【Cubism Editorのバージョン】Cubism Editor 4.1.05
【OS名・バージョン】Windows10
【機種名】za7r-67xt
【CPU】AMD Ryzen 7 5800X 8-Core Processor
【グラフィックボード】AMD Radeon RX 6700 XT
【メモリ】32GB
【不具合の状況】
・Live2dを.can3でMP4出力する際に発生した。
・音声ファイルを含むシーンを25枚ほど「全シーンを出力」で出力すると、6枚ほど音声の無いMP4が出力されていた。
・この現象は複数の.can3データで確認し、2回同じ出力をしても再現できた。
・その特定のシーンを一枚だけで出力すると、音声付きのMP4が出力された。
・Live2dのバージョンをv4.1.04に戻すことで解決した。
・v4.1.04で3つの.can3で「全シーンを出力」したが、音声の無いMP4は出力されなかった。

@ふじざくら

いつも弊社製品をご愛顧くださり誠にありがとうございます。
Live2Dスタッフでございます。
この度はご不便をおかけして誠に申し訳ございません。

調査のため、下記のものをDMにて送付いただけないでしょうか。
・問題の発生するcan3ファイル
・cmo3ファイル
・音声ファイル

【DMの送信手順】
1.この返信の投稿者名[ueno_staff]をクリックします。
2.右上の[メッセージ]をクリックします。
3.メッセージ編集画面が開きますので、アイコン[アップロード]をクリックしファイルを選択します。
4.下部の[メッセージ]をクリックし、ご送信ください。
(ファイルは圧縮していただくか、サイズが大きくて添付できない場合はアップロードサイトなどをご利用下さい)

お手数ではございますが、よろしくお願いいたします。

@ふじざくら
DMにて返信いただきありがとうございます。
規約の問題で送付不可となっているのは、音声ファイルについてでしょうか?
can3ファイル、cmo3ファイルについて問題がないようでしたら、
DMにて送付いただけますと幸いです。

いずれも不可ということでしたら、下記についてご回答いただけないでしょうか。

・各シーンの長さをご教示ください。
・各シーンにモデルは複数取り込まれているでしょうか。
複数の場合はいくつ入っているか、ご教示ください。
・各シーンは、それぞれ全く異なるシーンでしょうか、
それとも一部のみ異なるような、ほぼ複製したシーンでしょうか。

can3ファイル等を送付いただける際は、下記についてのみご回答をお願いいたします。
(送付不可の際は、併せてご回答ください)
・音声ファイルは各シーンにつき複数取り込まれているでしょうか。
複数の場合はいくつ入っているか、ご教示ください。

また、ログファイルをDMにて送付いただけないでしょうか。
【ログファイル取得方法】
Cubism Editorを開き、画面上部のメニューにあります[ヘルプ]より、
[ログファイルを開く]よりログファイルが表示されますので取得をお願いいたします。

ご確認のほど、よろしくお願いいたします。

申し訳ありません、cmo3ファイルも事情により送信できません。

・各シーンの長さをご教示ください。

シーンの長さは最短3.0秒最長4.0秒(30.00フレーム/秒)です。
問題のあったシーンは3秒・4秒・3.5秒のシーンなど秒数に共通はありませんでした。

・各シーンにモデルは複数取り込まれているでしょうか。
複数の場合はいくつ入っているか、ご教示ください。

全てのシーンに複数のcmo3ファイルが含まれています。問題のあったシーンに含まれるモデルは2つでした。

・各シーンは、それぞれ全く異なるシーンでしょうか、
それとも一部のみ異なるような、ほぼ複製したシーンでしょうか。

ほぼ複製したシーンではありません。秒数も違うので多くのパラメータを打ち直したシーンです。

・音声ファイルは各シーンにつき複数取り込まれているでしょうか。
複数の場合はいくつ入っているか、ご教示ください。

各シーンに複数音声ファイルが含まれています。ですが、問題のあったシーンはいずれも1つでした。
複数の音声ファイルを含んだシーンは音が出力されていました。
問題のあったシーンで使用した音声ファイルは、以前から使用していたもので4.1.05以外では問題ありませんでした。

DMにてログファイルを送信します。よろしくお願いいたします。

@ふじざくら
問題の発生するファイルにつきまして、ご教示いただきありがとうございます。
また、ログファイルを送付いただき、ありがとうございました。

これより調査を進めてまいりますが、
1シーンずつ書き出すことで、こちらの問題を回避していただけたらと存じます。

お手数をおかけして申し訳ございませんが、よろしくお願いいたします。

@ふじざくら
調査にお時間を頂きまして、申し訳ございません。

ご教示いただいた情報を基に検証いたしましたが、
問題を再現することができませんでした。

下記についてもご対応いただくことは可能でしょうか。

・音声ファイルの再インポートをお試しください。
・問題の発生するシーンはどのように作成されましたでしょうか。
(一から作成した、別のシーンを複製し作成した等)
・複数回、問題が発生したとのことですが、現象が発生するシーンは同じものでしょうか。
・問題が発生するシーンにつきまして、
タイムラインパレットの右側のスクリーンショットを送付いただけないでしょうか。
(添付画像の範囲をお願いいたします)

お手数ではございますが、ご確認をお願いいたします。

返信に気が付かなかったことを深くお詫びいたします。
申し訳ありませんでした。

結局こちらでも問題は解決できず、一年間Cubism Editor 4.1.04で動画を出力していたのですが、バージョンが変わったとのことで5.0.02に変更して出力してみました。
(cmo3ファイルから新しく作ったものです)
ですが同じ問題が発生してしまい、バグ報告を調べて返信に気が付きました。

・音声ファイルの再インポートをお試しください。

試してみましたが、改善しませんでした。

・複数回、問題が発生したとのことですが、現象が発生するシーンは同じものでしょうか。

今回のバージョンでは、ほとんどのシーンで音が無くなっていました。

(前回は特定のシーンのみでした)

・問題が発生するシーンにつきまして、

タイムラインパレットの右側のスクリーンショットを送付いただけないでしょうか。

(添付画像の範囲をお願いいたします)

タイムラインの右側というのはキーフレームの部分でしょうか。

作業環境はCubism Editorのバージョン以外、前回から変わっていません。

【Cubism Editorのバージョン】Cubism Editor 5.0.02

【OS名・バージョン】Windows10
【機種名】za7r-67xt
【CPU】AMD Ryzen 7 5800X 8-Core Processor
【グラフィックボード】AMD Radeon RX 6700 XT
【メモリ】32GB

【不具合の状況】
・Live2dを.can3でMP4出力する際に発生した。
・音声ファイルを含むシーンを80枚ほど「全シーンを出力」で出力すると、ほとんど音声の無いMP4が出力されていた。
・この現象は複数の.can3データで確認し、2回同じ出力をしても再現できた。
・その特定のシーンを一枚だけで出力すると、音声付きのMP4が出力された。
・Live2dのバージョンをv4.1.04に戻すことで解決した。
・v4.1.04で同一の.can3で「全シーンを出力」したが、音声の無いMP4は出力されなかった。

@ふじざくら
返信いただきまして、ありがとうございます。
昨日リリースされたバージョン5.0.03 beta1に、書き出した動画の音声に関しての修正が入っていますので、
問題が改善されているかご確認いただけますでしょうか。

また、画像を添付しておらず申し訳ございませんでした。
おっしゃる通り、キーフレームの部分を差しておりました。
もし現象が改善されていなかった場合は添付いただけますと幸いです。

なお、こちらの問題について現在まで同様の報告がないため、原因の特定が難しい状況です。
問題の発生するCAN3ファイルを送付いただきますと、より正確な調査を行えますので、
規約上の問題がないCAN3ファイルで現象を確認できるデータがあればお送りいただけますでしょうか。

送付いただける場合は、下記のサイトへアップロードをお願いいたします。

ご確認いただきますよう、よろしくお願いいたします。

バージョン5.0.03 beta1を試したところ、問題が解消されたいました。
本当にありがとうございます。

ですが原因究明のためデータが必要とのことで、バージョン5.0.02時点で不具合が出ていたcan3ファイルと出力したMP4をアップロードしました。前回も今回もデータの規約の都合上データを送ることができなかったのですが、cmoファイルを差し替えても同じ不具合が確認できたため、そのデータを提出いたしました。お手数ですが確認をお願いいたします。

まだ全てのcan3ファイルで確認したわけではありませんが、ひとまず問題が解消されてとても嬉しく思います。バージョン5のEditorは4に比べて非常に動作が軽く、MP4出力もとても早くなっており非常に快適です。ありがとうございます。

お手数をおかけして申し訳ありませんでした。